installed turbo and now my car wont start - The unofficial Honda Forum and Discussion Board Forums For Honda automobile and motorcycle enthusiasts.


Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 03-15-2017, 07:48 PM
Junior Member
Thread Starter
 
Join Date: Mar 2017
Posts: 1
Default installed turbo and now my car wont start

i recently put a full bolt on turbo kit on my 04 civic. d17 vtec engine. the car spins over but wont start. it did crank for 2-3 seconds and shut right off. a few attempts from there but never started again. any helpful advice to get it to actually start and idle/stay running?
Reply With Quote
  #2  
Old 06-15-2017, 09:29 AM
Junior Member
 
Join Date: Jun 2017
Posts: 16
Default

Maybe you are flooding the engine with no fuel management? I know a guy who got on a deal lease in DSRLeasing and had a turbo installed there, but they helped him and he mentioned something about this being a cause.
Reply With Quote
  #3  
Old 06-15-2017, 12:05 PM
Member
 
Join Date: May 2017
Location: Birmingham Alabama
Posts: 71
Default

Its going to be hard to advise you on this issue with out a LOT of info about exactly what has been done.. what tune you are running and what size injectors.. etc..
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Has anyone installed a remote started themselves? lurky CR-V Forum 2 12-03-2013 10:49 AM
installed after market radio lost dash light and rear running lights.. duallyguy General Tech Help 0 08-15-2013 07:08 PM
Honda Accord 97, Took Out Battery Temporarily now it wont Crank/Start! xang0 Honda Accord Forum 0 07-05-2009 06:00 PM
[HELP] Installed a cone filter, then engine light went on! Wai General Tech Help 3 07-01-2009 03:16 AM
95 honda overheated and now won't start???? shad9876 Honda Accord Forum 3 09-01-2008 10:31 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 07:32 PM.