new honda outboard 15hp no visible cooling - The unofficial Honda Forum and Discussion Board Forums For Honda automobile and motorcycle enthusiasts.

Thread Tools Search this Thread
Old 03-04-2018, 07:32 PM
Junior Member
Thread Starter
Join Date: Mar 2018
Posts: 1
Default new honda outboard 15hp no visible cooling

New to forum. Bought brand new Honda 15hp in December. Used it 4 times. Last time started was about 2 months ago. Today, wanted to start engine in driveway with standard flush-clip-style prong to get engine up and running, rather than at dock. PROBLEM: No water is flowing from side of engine as it always does. Tried about 4 times running for about 15 seconds, and no more. Any ideas? I cleaned the vents, thats all. Gas is a few months old, plenty of oil.
Reply With Quote

Related Topics
Thread Thread Starter Forum Replies Last Post
honda bf 130 outboard won't start ultimatesalmonslayer General Tech Help 1 09-17-2017 05:50 AM
Honda BF30 Outboard but generally any Outboard andyk58 Honda Marine Engines 0 09-17-2017 05:37 AM
94 Honda Accord Radiator Cooling fan issues CRockerDad General Tech Help 2 09-21-2012 01:36 PM
New Guy here .. Needs cooling help ! Jester419 New Member Area 0 09-26-2008 07:41 PM
1996 Honda Accord 4-cyl Engine Cooling Fans tferstl General Tech Help 1 06-09-2008 06:06 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Featured Sponsors
Vendor Directory

All times are GMT -5. The time now is 08:06 PM.

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to and affiliated sites.