Fit Forum This sporty new sub-compact combines the efficiency of a economy car with the interior room of some minivans.

Fit miss in the motor

  #1  
Old 08-19-2009, 09:43 PM
Junior Member
Thread Starter
Join Date: Oct 2008
Location: Halifax Nova Scotia Canada
Posts: 6
Default Fit miss in the motor

my 2007 Fit has a mis in the Motor at Idle and on the highway around 90-100 kms.
I went to the dealer, they said it doesn't show on the computer, I said, what about the timing chain or a tuneup? No it's not that.... now that will be $45.00 thank you.
 
  #2  
Old 08-20-2009, 02:30 AM
Super Moderator
Join Date: Mar 2006
Location: Hemet Ca.
Posts: 4,480
Default

Hey! That is not right, if they charged you 45.00, they should have showed you the fix for the miss. and are you out of warranty? 36k, 3 yrs.
 
  #3  
Old 09-06-2015, 03:42 PM
Junior Member
Join Date: Aug 2015
Location: Dallas, TX
Posts: 7
Default

My 07 Fit has the same issue and the dealer told me the same story. My son was using it to deliver Pizza and the car started stalling at traffic lights. Mine only misses at idle and I have never had it stall.

I took it to my local mechanic and he couldn't find anything wrong. Eventually the check engine light illuminated and the codes he pulled were random misfires. On Tuesday, I'm having him replace the plugs, the coils and adjust the valves.
 
  #4  
Old 10-02-2015, 04:08 PM
Junior Member
Join Date: Aug 2015
Location: Dallas, TX
Posts: 7
Default

My local mechanic pulled the codes and discovered that all four cylinders were randomly missing. He suggested that the engine computer might be the problem. He bought a used one from eBay and reprogrammed it. The miss fire was still present but now only on the number one cylinder. He then replaced the coil pack and the spark plug for that cylinder which cured the problem. I think the problem was always on just one cylinder but the faulty computer was indicating incorrectly that all four were missing.
 
  #5  
Old 02-08-2019, 06:12 PM
Junior Member
Join Date: Feb 2019
Location: In my motor home, towing Honda Fit
Posts: 1
Default

Honda Fit 2013. Has anyone had a spark plug thread stripped and had to have it re-threaded? My check engine light came on then started blinking. Had it towed in. #2 spark plug was stripped. It had to be sent out to a head shop to be re-threaded. I bought it with 22,000 miles on it. It is now at 46,000 miles and I’ve never had any work done that involved the spark plugs. Mystery to everyone. $3081 to get it repaired! Since I am the 3rd owner nothing under warranty, of course. No recalls on it.
 
  #6  
Old 02-09-2019, 01:43 AM
Super Moderator
Join Date: Mar 2006
Location: Hemet Ca.
Posts: 4,480
Default

welcome to the forum. Oknative1946. yes I have but on a mopar long time ago, I sent it our to fix after taking the head off. my 07 fit with 285k+ miles, never in 3 time spark pkug change has any spark plug stripped the threads. rare item to happen to a well sealed spark plug system.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
cutlas
CR-V Forum
5
01-23-2016 06:08 AM
frett
Honda Accord Forum
1
07-02-2015 05:57 AM
PlaneguyTed
General Tech Help
0
02-28-2014 10:36 AM
PlaneguyTed
CR-V Forum
0
02-27-2014 01:54 PM
Kickinwing96
Fit Forum
2
11-05-2010 06:29 AM


Thread Tools
Search this Thread
Quick Reply: Fit miss in the motor


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.