New Member Area New to HF? Stop in tell us about yourself.

2000 Accord EX issues

  #1  
Old 04-11-2019, 07:20 AM
Junior Member
Thread Starter
Join Date: Apr 2019
Posts: 4
Default 2000 Accord EX issues

When I first start up the car, something squeals off and on. The serpentine belt was replaced last November. It started to squeal in January. It will stop squealing after awhile. Also, after first turning it on, it will putter. When I try to accelerate, the car has to think about it for a long time. The plugs have been replaced, distributor and cap have been replaced. The check engine light puts out the code for the O2 sensors. Those have been tested and are fine.

Any thoughts? I don't feel safe driving my car because it won't get up and go when I first get it going. Eventually, it acts normal, but it won't keep the RPMs up adequately.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Gavin Jones
Honda Accord Forum
2
07-27-2016 05:08 AM
socket7
Honda Accord Forum
1
04-08-2007 01:07 AM
Lazzyone
Honda Accord Forum
0
10-05-2006 11:04 AM
Lazzyone
General Tech Help
1
10-05-2006 10:58 AM


Thread Tools
Search this Thread
Quick Reply: 2000 Accord EX issues


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.